Vulnerability · Published Dec 19, 2023 · Assigned by apache
CVE-2023-49734Apache Superset: Privilege Escalation Vulnerability
High 7.7
In plain English
A high-severity incorrect authorization in Apache Superset from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 61% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
An authenticated Gamma user has the ability to create a dashboard and add charts to it, this user would automatically become one of the owners of the charts allowing him to incorrectly have write permissions to these charts.This issue affects Apache Superset: before 2.1.2, from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 3.0.2 or 2.1.3, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | apache-superset | 2.1.3 | GHSA-g49j-j489-3xpf |
| PyPI | apache-superset | 3.0.2 | GHSA-g49j-j489-3xpf |
| PyPI | apache-superset | 2.1.3, 3.0.2 | PYSEC-2026-1180 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Superset | 0 – before 2.1.23.0.0 – before 3.0.2 |
Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N