Vulnerability · Published Dec 4, 2023 · Assigned by GitHub_M

CVE-2023-49288Denial of Service in HTTP Collapsed Forwarding in Squid

High 8.6

In plain English

A high-severity use-after-free in squid from squid-cache. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 4.8% (higher than 92% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.6High
Exploit odds (30 days)4.8%top 8.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Affected versions of squid are subject to a a Use-After-Free bug which can lead to a Denial of Service attack via collapsed forwarding. All versions of Squid from 3.5 up to and including 5.9 configured with "collapsed_forwarding on" are vulnerable. Configurations with "collapsed_forwarding off" or without a "collapsed_forwarding" directive are not vulnerable. This bug is fixed by Squid version 6.0.1. Users are advised to upgrade. Users unable to upgrade should remove all collapsed_forwarding lines from their squid.conf.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8libecap1.0.1-2.module_el8.6.0+3048+383bc947ALSA-2023:7668
AlmaLinux:8libecap1.0.1-2.module_el8.6.0+2741+01592ae8ALSA-2023:7668
AlmaLinux:8libecap-devel1.0.1-2.module_el8.6.0+2741+01592ae8ALSA-2023:7668
AlmaLinux:8libecap-devel1.0.1-2.module_el8.6.0+3048+383bc947ALSA-2023:7668
AlmaLinux:8squid7:4.15-7.module_el8.9.0+3696+b881db49.3ALSA-2023:7668
Alpine:v3.20squid6.1-r0ALPINE-CVE-2023-49288
Alpine:v3.21squid6.1-r0ALPINE-CVE-2023-49288
Alpine:v3.22squid6.1-r0ALPINE-CVE-2023-49288
Alpine:v3.23squid6.1-r0ALPINE-CVE-2023-49288
Alpine:v3.24squid6.1-r0ALPINE-CVE-2023-49288
Debian:12squidno fix listedDEBIAN-CVE-2023-49288
Debian:13squid6.1-1DEBIAN-CVE-2023-49288
Debian:14squid6.1-1DEBIAN-CVE-2023-49288
Ubuntu:22.04:LTSsquid5.7-0ubuntu0.22.04.4UBUNTU-CVE-2023-49288
Ubuntu:22.04:LTSsquid5.7-0ubuntu0.22.04.4USN-6728-1

Affected products (as reported)

VendorProductVersions
squid-cache squid >= 3.5, < 6.0.1

Weakness: CWE-416 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H

References