Vulnerability · Published Dec 21, 2023 · Assigned by GitHub_M

CVE-2023-49086Cacti is vulnerable to cross-Site scripting (XSS) DOM

Medium 5.4

In plain English

A medium-severity cross-site scripting in cacti from Cacti. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.5% (higher than 74% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)1.5%top 25.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Cacti is a robust performance and fault management framework and a frontend to RRDTool - a Time Series Database (TSDB). A vulnerability in versions prior to 1.2.27 bypasses an earlier fix for CVE-2023-39360, therefore leading to a DOM XSS attack. Exploitation of the vulnerability is possible for an authorized user. The vulnerable component is the `graphs_new.php`. The impact of the vulnerability is execution of arbitrary JavaScript code in the attacked user's browser. This issue has been patched in version 1.2.27.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20cacti1.2.26-r0ALPINE-CVE-2023-49086
Alpine:v3.21cacti1.2.26-r0ALPINE-CVE-2023-49086
Alpine:v3.22cacti1.2.26-r0ALPINE-CVE-2023-49086
Alpine:v3.23cacti1.2.26-r0ALPINE-CVE-2023-49086
Alpine:v3.24cacti1.2.26-r0ALPINE-CVE-2023-49086
Debian:12cacti1.2.24+ds1-1+deb12u2DEBIAN-CVE-2023-49086
Debian:12cacti1.2.24+ds1-1+deb12u2DSA-5646-1
Debian:13cacti1.2.26+ds1-1DEBIAN-CVE-2023-49086
Debian:14cacti1.2.26+ds1-1DEBIAN-CVE-2023-49086

Affected products (as reported)

VendorProductVersions
Cacti cacti < 1.2.27

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

References