Vulnerability · Published Nov 28, 2023 · Assigned by GitHub_M

CVE-2023-49075Pimcore Admin UI has Two Factor Authentication disabled for non admin security firewalls

High 8.5

In plain English

A high-severity security flaw in admin-ui-classic-bundle from pimcore. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 73% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.5High
Exploit odds (30 days)1.4%top 26.7% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

The Admin Classic Bundle provides a Backend UI for Pimcore. `AdminBundle\Security\PimcoreUserTwoFactorCondition` introduced in v11 disable the two factor authentication for all non-admin security firewalls. An authenticated user can access the system without having to provide the two factor credentials. This issue has been patched in version 1.2.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistpimcore/admin-ui-classic-bundle1.2.2GHSA-9wwg-r3c7-4vfg

Affected products (as reported)

VendorProductVersions
pimcore admin-ui-classic-bundle < 1.2.2

Weakness: CWE-308 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H

References