Vulnerability · Published Dec 21, 2023 · Assigned by apache

CVE-2023-48291Apache Airflow: Improper access control to DAG resources

Medium 4.3

In plain English

A medium-severity security flaw in Apache Airflow from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.8% (higher than 79% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)4.3Medium
Exploit odds (30 days)1.8%top 21.4% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Apache Airflow, in versions prior to 2.8.0, contains a security vulnerability that allows an authenticated user with limited access to some DAGs, to craft a request that could give the user write access to various DAG resources for DAGs that the user had no access to, thus, enabling the user to clear DAGs they shouldn't. This is a missing fix for CVE-2023-42792 in Apache Airflow 2.7.2  Users of Apache Airflow are strongly advised to upgrade to version 2.8.0 or newer to mitigate the risk associated with this vulnerability.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIapache-airflow2.8.0GHSA-8f57-wcmg-4jmh
PyPIapache-airflow2.8.0PYSEC-2023-265

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Airflow 0 – before 2.8.0

Weakness: CWE-668

References