Vulnerability · Published Nov 20, 2023 · Assigned by GitHub_M

CVE-2023-48218Strapi Protected Populate Plugin leaking fields if the request fields where empty or only fields selected where not populatable

Medium 5.3

In plain English

A medium-severity incorrect authorization in strapi-plugin-protected-populate from strapi-community. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.6%top 51.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

The Strapi Protected Populate Plugin protects `get` endpoints from revealing too much information. Prior to version 1.3.4, users were able to bypass the field level security. Users who tried to populate something that they didn't have access to could populate those fields anyway. This issue has been patched in version 1.3.4. There are no known workarounds.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmstrapi-plugin-protected-populate1.3.4GHSA-6h67-934r-82g7

Affected products (as reported)

VendorProductVersions
strapi-community strapi-plugin-protected-populate < 1.3.4

Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

References