Vulnerability · Published Nov 14, 2023 · Assigned by GitHub_M

CVE-2023-47631vantage6 Node accepts non-whitelisted algorithms from malicious server

High 7.2

In plain English

A high-severity insufficient verification of data authenticity in vantage6 from vantage6. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.2High
Exploit odds (30 days)0.4%top 61.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

vantage6 is a framework to manage and deploy privacy enhancing technologies like Federated Learning (FL) and Multi-Party Computation (MPC). In affected versions a node does not check if an image is allowed to run if a `parent_id` is set. A malicious party that breaches the server may modify it to set a fake `parent_id` and send a task of a non-whitelisted algorithm. The node will then execute it because the `parent_id` that is set prevents checks from being run. This impacts all servers that are breached by an expert user. This vulnerability has been patched in version 4.1.2. All users are advised to upgrade. There are no known workarounds for this vulnerability.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIvantage6-node4.1.2GHSA-vc3v-ppc7-v486
PyPIvantage6-node4.1.2PYSEC-2023-303
PyPIvantage6-server4.1.2GHSA-vc3v-ppc7-v486
PyPIvantage6-server4.1.2PYSEC-2023-304

Affected products (as reported)

VendorProductVersions
vantage6 vantage6 < 4.1.2

Weakness: CWE-345 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

References