Vulnerability · Published Dec 21, 2023 · Assigned by apache
CVE-2023-47265Apache Airflow: DAG Params alllow to embed unchecked Javascript
Medium 5.4
In plain English
A medium-severity cross-site scripting in Apache Airflow from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 72% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Apache Airflow, versions 2.6.0 through 2.7.3 has a stored XSS vulnerability that allows a DAG author to add an unbounded and not-sanitized javascript in the parameter description field of the DAG. This Javascript can be executed on the client side of any of the user who looks at the tasks in the browser sandbox. While this issue does not allow to exit the browser sandbox or manipulation of the server-side data - more than the DAG author already has, it allows to modify what the user looking at the DAG details sees in the browser - which opens up all kinds of possibilities of misleading other users. Users of Apache Airflow are recommended to upgrade to version 2.8.0 or newer to mitigate the risk associated with this vulnerability
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | apache-airflow | 2.8.0b1 | GHSA-pxch-wr7m-rwxj |
| PyPI | apache-airflow | 2.8.0b1 | PYSEC-2023-264 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Airflow | 2.6.0 – before 2.8.0 |
Weakness: CWE-79