Vulnerability · Published Nov 10, 2023 · Assigned by GitHub_M
CVE-2023-47121Discourse SSRF vulnerability in Embedding
Low 3.4
In plain English
A low-severity server-side request forgery in discourse from discourse. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities).
Official description
Discourse is an open source platform for community discussion. Prior to version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches, the embedding feature is susceptible to server side request forgery. The issue is patched in version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches. As a workaround, disable the Embedding feature.
Affected products (as reported)
Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N
References
- https://github.com/discourse/discourse/security/advisories/GHSA-hp24-94qf-8cgc x_refsource_CONFIRM
- https://github.com/discourse/discourse/commit/24cca10da731734af4e9748de99a508d586e59f1 x_refsource_MISC
- https://github.com/discourse/discourse/commit/5f20748e402223b265e6fee381472c14e2604da6 x_refsource_MISC