Vulnerability · Published Sep 14, 2023 · Assigned by HashiCorp
CVE-2023-4680Vault's Transit Secrets Engine Allowed Nonce Specified without Convergent Encryption
Medium 6.8
In plain English
A medium-severity security flaw in Vault from HashiCorp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
HashiCorp Vault and Vault Enterprise transit secrets engine allowed authorized users to specify arbitrary nonces, even with convergent encryption disabled. The encrypt endpoint, in combination with an offline attack, could be used to decrypt arbitrary ciphertext and potentially derive the authentication subkey when using transit secrets engine without convergent encryption. Introduced in 1.6.0 and fixed in 1.14.3, 1.13.7, and 1.12.11.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/hashicorp/vault | 1.12.11 | GHSA-v84f-6r39-cpfc |
| Go | github.com/hashicorp/vault | 1.13.7 | GHSA-v84f-6r39-cpfc |
| Go | github.com/hashicorp/vault | 1.14.3 | GHSA-v84f-6r39-cpfc |
| Go | github.com/hashicorp/vault | 1.12.11, 1.13.7, 1.14.3 | GO-2023-2063 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| HashiCorp | Vault | 1.14.0 – before 1.14.31.13.0 – before 1.13.71.12.0 – before 1.12.111.6.0 – before 1.12.0 |
| HashiCorp | Vault Enterprise | 1.14.0 – before 1.14.31.13.0 – before 1.13.71.12.0 – before 1.12.111.6.0 – before 1.12.0 |
Weakness: CWE-323 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N