Vulnerability · Published Nov 28, 2023 · Assigned by apache

CVE-2023-46589Apache Tomcat: HTTP request smuggling via malformed trailer headers

High 7.5

In plain English

A high-severity security flaw in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.7% (higher than 86% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)2.7%top 14.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.1.15, from 9.0.0-M1 through 9.0.82 and from 8.5.0 through 8.5.95 did not correctly parse HTTP trailer headers. A trailer header that exceeded the header size limit could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M11 onwards, 10.1.16 onwards, 9.0.83 onwards or 8.5.96 onwards, which fix the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8tomcat1:9.0.62-27.el8_9.3ALSA-2024:0539
AlmaLinux:9tomcat1:9.0.62-37.el9_3.2ALSA-2024:1134
AlmaLinux:8tomcat-admin-webapps1:9.0.62-27.el8_9.3ALSA-2024:0539
AlmaLinux:9tomcat-admin-webapps1:9.0.62-37.el9_3.2ALSA-2024:1134
AlmaLinux:8tomcat-docs-webapp1:9.0.62-27.el8_9.3ALSA-2024:0539
AlmaLinux:9tomcat-docs-webapp1:9.0.62-37.el9_3.2ALSA-2024:1134
AlmaLinux:8tomcat-el-3.0-api1:9.0.62-27.el8_9.3ALSA-2024:0539
AlmaLinux:9tomcat-el-3.0-api1:9.0.62-37.el9_3.2ALSA-2024:1134
AlmaLinux:8tomcat-jsp-2.3-api1:9.0.62-27.el8_9.3ALSA-2024:0539
AlmaLinux:9tomcat-jsp-2.3-api1:9.0.62-37.el9_3.2ALSA-2024:1134
AlmaLinux:8tomcat-lib1:9.0.62-27.el8_9.3ALSA-2024:0539
AlmaLinux:9tomcat-lib1:9.0.62-37.el9_3.2ALSA-2024:1134
AlmaLinux:8tomcat-servlet-4.0-api1:9.0.62-27.el8_9.3ALSA-2024:0539
AlmaLinux:9tomcat-servlet-4.0-api1:9.0.62-37.el9_3.2ALSA-2024:1134
AlmaLinux:8tomcat-webapps1:9.0.62-27.el8_9.3ALSA-2024:0539
AlmaLinux:9tomcat-webapps1:9.0.62-37.el9_3.2ALSA-2024:1134
Debian:12tomcat1010.1.6-1+deb12u2DEBIAN-CVE-2023-46589
Debian:12tomcat1010.1.6-1+deb12u2DSA-5665-1
Debian:13tomcat1010.1.16-1DEBIAN-CVE-2023-46589
Debian:14tomcat1010.1.16-1DEBIAN-CVE-2023-46589
Debian:12tomcat99.0.70-2DEBIAN-CVE-2023-46589
Debian:13tomcat99.0.70-2DEBIAN-CVE-2023-46589
Debian:14tomcat99.0.70-2DEBIAN-CVE-2023-46589
Mavenorg.apache.tomcat.embed:tomcat-embed-core10.1.16GHSA-fccv-jmmp-qg76
Mavenorg.apache.tomcat.embed:tomcat-embed-core9.0.83GHSA-fccv-jmmp-qg76
Mavenorg.apache.tomcat.embed:tomcat-embed-core8.5.96GHSA-fccv-jmmp-qg76
Mavenorg.apache.tomcat.embed:tomcat-embed-core11.0.0-M11GHSA-fccv-jmmp-qg76
Mavenorg.apache.tomcat:tomcat-catalina11.0.0-M11GHSA-fccv-jmmp-qg76
Mavenorg.apache.tomcat:tomcat-catalina10.1.16GHSA-fccv-jmmp-qg76
Mavenorg.apache.tomcat:tomcat-catalina9.0.83GHSA-fccv-jmmp-qg76
Mavenorg.apache.tomcat:tomcat-catalina8.5.96GHSA-fccv-jmmp-qg76
Mavenorg.apache.tomcat:tomcat-coyote11.0.0-M11GHSA-fccv-jmmp-qg76
Rocky Linux:8tomcat1:9.0.62-27.el8_9.3RLSA-2024:0539
Ubuntu:24.04:LTStomcat99.0.70-2ubuntu0.1USN-7032-1
Ubuntu:24.04:LTStomcat99.0.70-2ubuntu0.1UBUNTU-CVE-2023-46589
Ubuntu:25.10tomcat99.0.70-2ubuntu1.1UBUNTU-CVE-2023-46589

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.0-M1 – through 11.0.0-M1010.1.0-M1 – through 10.1.159.0.0-M1 – through 9.0.828.5.0 – through 8.5.95

Weakness: CWE-444 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

References