Vulnerability · Published Oct 10, 2023 · Assigned by apache

CVE-2023-45648Apache Tomcat: Trailer header parsing too lenient

Medium 5.3

In plain English

A medium-severity improper input validation in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 5.9% (higher than 93% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)5.9%top 6.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Nuclei

Official description

Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M11, from 10.1.0-M1 through 10.1.13, from 9.0.0-M1 through 9.0.81 and from 8.5.0 through 8.5.93 did not correctly parse HTTP trailer headers. A specially crafted, invalid trailer header could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M12 onwards, 10.1.14 onwards, 9.0.81 onwards or 8.5.94 onwards, which fix the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8tomcat1:9.0.62-27.el8_9.2ALSA-2024:0125
AlmaLinux:9tomcat1:9.0.62-37.el9_3.1ALSA-2024:0474
AlmaLinux:8tomcat-admin-webapps1:9.0.62-27.el8_9.2ALSA-2024:0125
AlmaLinux:9tomcat-admin-webapps1:9.0.62-37.el9_3.1ALSA-2024:0474
AlmaLinux:8tomcat-docs-webapp1:9.0.62-27.el8_9.2ALSA-2024:0125
AlmaLinux:9tomcat-docs-webapp1:9.0.62-37.el9_3.1ALSA-2024:0474
AlmaLinux:8tomcat-el-3.0-api1:9.0.62-27.el8_9.2ALSA-2024:0125
AlmaLinux:9tomcat-el-3.0-api1:9.0.62-37.el9_3.1ALSA-2024:0474
AlmaLinux:8tomcat-jsp-2.3-api1:9.0.62-27.el8_9.2ALSA-2024:0125
AlmaLinux:9tomcat-jsp-2.3-api1:9.0.62-37.el9_3.1ALSA-2024:0474
AlmaLinux:8tomcat-lib1:9.0.62-27.el8_9.2ALSA-2024:0125
AlmaLinux:9tomcat-lib1:9.0.62-37.el9_3.1ALSA-2024:0474
AlmaLinux:8tomcat-servlet-4.0-api1:9.0.62-27.el8_9.2ALSA-2024:0125
AlmaLinux:9tomcat-servlet-4.0-api1:9.0.62-37.el9_3.1ALSA-2024:0474
AlmaLinux:8tomcat-webapps1:9.0.62-27.el8_9.2ALSA-2024:0125
AlmaLinux:9tomcat-webapps1:9.0.62-37.el9_3.1ALSA-2024:0474
Debian:12tomcat1010.1.6-1+deb12u1DEBIAN-CVE-2023-45648
Debian:12tomcat1010.1.6-1+deb12u1DSA-5521-1
Debian:13tomcat1010.1.14-1DEBIAN-CVE-2023-45648
Debian:14tomcat1010.1.14-1DEBIAN-CVE-2023-45648
Debian:12tomcat99.0.70-2DEBIAN-CVE-2023-45648
Debian:13tomcat99.0.70-2DEBIAN-CVE-2023-45648
Debian:14tomcat99.0.70-2DEBIAN-CVE-2023-45648
Mavenorg.apache.tomcat.embed:tomcat-embed-core10.1.14GHSA-r6j3-px5g-cq3x
Mavenorg.apache.tomcat.embed:tomcat-embed-core9.0.81GHSA-r6j3-px5g-cq3x
Mavenorg.apache.tomcat.embed:tomcat-embed-core8.5.94GHSA-r6j3-px5g-cq3x
Mavenorg.apache.tomcat.embed:tomcat-embed-core11.0.0-M12GHSA-r6j3-px5g-cq3x
Mavenorg.apache.tomcat:tomcat9.0.81GHSA-r6j3-px5g-cq3x
Mavenorg.apache.tomcat:tomcat11.0.0-M12GHSA-r6j3-px5g-cq3x
Mavenorg.apache.tomcat:tomcat10.1.14GHSA-r6j3-px5g-cq3x
Mavenorg.apache.tomcat:tomcat8.5.94GHSA-r6j3-px5g-cq3x
Mavenorg.apache.tomcat:tomcat-coyote8.5.94GHSA-r6j3-px5g-cq3x
Mavenorg.apache.tomcat:tomcat-coyote9.0.81GHSA-r6j3-px5g-cq3x
Mavenorg.apache.tomcat:tomcat-coyote10.1.14GHSA-r6j3-px5g-cq3x
Mavenorg.apache.tomcat:tomcat-coyote11.0.0-M12GHSA-r6j3-px5g-cq3x
Ubuntu:25.10tomcat99.0.70-2ubuntu3UBUNTU-CVE-2023-45648

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.0-M1 – through 11.0.0-M1110.1.0-M1 – through 10.1.139.0.0-M1 – through 9.0.818.5.0 – through 8.5.93

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

References