Vulnerability · Published Jun 24, 2024 · Assigned by cisa-cg

CVE-2023-45195Adminer and AdminerEvo SSRF

Medium 6.9

In plain English

A medium-severity server-side request forgery in Adminer from Adminer. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.4%top 64.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Adminer and AdminerEvo are vulnerable to SSRF via database connection fields. This could allow an unauthenticated remote attacker to enumerate or access systems the attacker would not otherwise have access to. Adminer is no longer supported, but this issue was fixed in AdminerEvo version 4.8.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12adminerno fix listedDEBIAN-CVE-2023-45195
Debian:13adminer4.8.1-4DEBIAN-CVE-2023-45195
Debian:14adminer4.8.1-4DEBIAN-CVE-2023-45195
Ubuntu:22.04:LTSadminerno fix listedUBUNTU-CVE-2023-45195
Ubuntu:24.04:LTSadminerno fix listedUBUNTU-CVE-2023-45195
Ubuntu:25.10adminerno fix listedUBUNTU-CVE-2023-45195
Ubuntu:26.04:LTSadminerno fix listedUBUNTU-CVE-2023-45195
Ubuntu:26.10adminerno fix listedUBUNTU-CVE-2023-45195

Affected products (as reported)

VendorProductVersions
Adminer Adminer 0 – through *cpe:2.3:a:adminer:adminer:0:*:*:*:*:*:*:* – through cpe:2.3:a:adminer:adminer:*:*:*:*:*:*:*:*
AdminerEvo AdminerEvo 4.8.2 – before 4.8.4cpe:2.3:a:adminerevo:adminerevo:0:*:*:*:*:*:*:* – before cpe:2.3:a:adminerevo:adminerevo:4.8.4:*:*:*:*:*:*:*

Weakness: CWE-918 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N/AU:Y

References