Vulnerability · Published Oct 16, 2023 · Assigned by GitHub_M

CVE-2023-45148Rate limiter not working reliable when Memcached is installed in Nextcloud

Medium 4.3

In plain English

A medium-severity security flaw in security-advisories from nextcloud. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities).

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.9%top 40.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Nextcloud is an open source home cloud server. When Memcached is used as `memcache.distributed` the rate limiting in Nextcloud Server could be reset unexpectedly resetting the rate count earlier than intended. Users are advised to upgrade to versions 25.0.11, 26.0.6 or 27.1.0. Users unable to upgrade should change their config setting `memcache.distributed` to `\OC\Memcache\Redis` and install Redis instead of Memcached.

Affected products (as reported)

VendorProductVersions
nextcloud security-advisories >= 25.0.0, < 25.0.11>= 26.0.0, < 26.0.6>= 27.0.0, < 27.1.0

Weakness: CWE-307 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

References