Vulnerability · Published Jan 31, 2024 · Assigned by apache
CVE-2023-44312Apache ServiceComb Service-Center: attacker can query all environment variables of the service-center server
Medium 5.8
In plain English
A medium-severity information exposure in Apache ServiceComb Service-Center from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)5.8Medium
Exploit odds (30 days)0.8%top 42.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Exposure of Sensitive Information to an Unauthorized Actor in Apache ServiceComb Service-Center.This issue affects Apache ServiceComb Service-Center before 2.1.0 (include). Users are recommended to upgrade to version 2.2.0, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/apache/servicecomb-service-center | 2.2.0 | GHSA-r8xp-52mq-rmm8 |
| Go | github.com/apache/servicecomb-service-center | no fix listed | GO-2024-2496 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache ServiceComb Service-Center | 0 – through 2.1.0 |
Weakness: CWE-200 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N