Vulnerability · Published Oct 24, 2023 · Assigned by GitHub_M
CVE-2023-43795WPS Server Side Request Forgery in GeoServer
High 8.6
In plain English
A high-severity server-side request forgery in geoserver from geoserver. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 69.0% (higher than 99.4% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei. Fixed versions are available - upgrade the affected package.
Official description
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. The OGC Web Processing Service (WPS) specification is designed to process information from any server using GET and POST requests. This presents the opportunity for Server Side Request Forgery. This vulnerability has been patched in version 2.22.5 and 2.23.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.geoserver.extension:gs-wps-core | 2.22.5 | GHSA-5pr3-m5hm-9956 |
| Maven | org.geoserver.extension:gs-wps-core | 2.23.2 | GHSA-5pr3-m5hm-9956 |
Affected products (as reported)
Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
References
- https://github.com/geoserver/geoserver/security/advisories/GHSA-5pr3-m5hm-9956 x_refsource_CONFIRM