Vulnerability · Published Oct 16, 2023 · Assigned by apache
CVE-2023-43666Apache InLong: General user Unauthorized access User Management
Medium 6.5
In plain English
A medium-severity insufficient verification of data authenticity in Apache InLong from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Insufficient Verification of Data Authenticity vulnerability in Apache InLong.This issue affects Apache InLong: from 1.4.0 through 1.8.0, General user can view all user data like Admin account. Users are advised to upgrade to Apache InLong's 1.9.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/8623
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.inlong:inlong | 1.9.0 | GHSA-wj6q-chpv-mcrx |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache InLong | 1.4.0 – through 1.8.0 |
Weakness: CWE-345
References
- https://lists.apache.org/thread/scbgh3ty3xcxm3q33r2t9f42gwwo1why vendor-advisory