Vulnerability · Published Oct 14, 2023 · Assigned by apache
CVE-2023-42780Apache Airflow: Improper access control vulnerability in the "List dag warnings" feature
Medium 6.5
In plain English
A medium-severity information exposure in Apache Airflow from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 73% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Apache Airflow, versions prior to 2.7.2, contains a security vulnerability that allows authenticated users of Airflow to list warnings for all DAGs, even if the user had no permission to see those DAGs. It would reveal the dag_ids and the stack-traces of import errors for those DAGs with import errors. Users of Apache Airflow are advised to upgrade to version 2.7.2 or newer to mitigate the risk associated with this vulnerability.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | apache-airflow | 2.7.2 | GHSA-cgx2-rrmr-jx43 |
| PyPI | apache-airflow | 2.7.2 | PYSEC-2023-202 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Airflow | 0 – before 2.7.2 |
Weakness: CWE-200