Vulnerability · Published Sep 26, 2023 · Assigned by GitHub_M

CVE-2023-42460_abi_decode input not validated in complex expressions in Vyper

Medium 5.3

In plain English

A medium-severity security flaw in vyper from vyperlang. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.7%top 47.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Vyper is a Pythonic Smart Contract Language for the EVM. The `_abi_decode()` function does not validate input when it is nested in an expression. Uses of `_abi_decode()` can be constructed which allow for bounds checking to be bypassed resulting in incorrect results. This issue has not yet been fixed, but a fix is expected in release `0.3.10`. Users are advised to reference pull request #3626.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIvyper0.3.10GHSA-cx2q-hfxr-rj97
PyPIvyper0.3.10PYSEC-2023-191

Affected products (as reported)

VendorProductVersions
vyperlang vyper >= 0.3.4, < 0.3.10

Weakness: CWE-682 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N

References