Vulnerability · Published Sep 11, 2023 · Assigned by GitHub_M

CVE-2023-41336Prevent injection of invalid entity ids for "autocomplete" fields in symfony ux-autocomplete

Medium 6.5

In plain English

A medium-severity improper input validation in ux-autocomplete from symfony. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.6%top 49.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

ux-autocomplete is a JavaScript Autocomplete functionality for Symfony. Under certain circumstances, an attacker could successfully submit an entity id for an `EntityType` that is *not* part of the valid choices. The problem has been fixed in `symfony/ux-autocomplete` version 2.11.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistsymfony/ux-autocomplete2.11.2GHSA-4cpv-669c-r79x

Affected products (as reported)

VendorProductVersions
symfony ux-autocomplete < 2.11.2

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

References