Vulnerability · Published Nov 17, 2023 · Assigned by mitre

CVE-2023-41102

High 7.5

In plain English

A high-severity uncontrolled resource consumption in the opennds package (Debian). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 62% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)1.0%top 37.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

An issue was discovered in the captive portal in OpenNDS before version 10.1.3. It has multiple memory leaks due to not freeing up allocated memory. This may lead to a Denial-of-Service condition due to the consumption of all available memory. Affected OpenNDS before version 10.1.3 fixed in OpenWrt master and OpenWrt 23.05 on 23. November by updating OpenNDS to version 10.2.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12openndsno fix listedDEBIAN-CVE-2023-41102
Debian:13opennds10.2.0+dfsg-1DEBIAN-CVE-2023-41102

Affected products (as reported)

VendorProductVersions
n/a n/a n/a

Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References