Vulnerability · Published Sep 13, 2023 · Assigned by apache

CVE-2023-41081Apache Tomcat Connectors: Unexpected use of first declared worker in mod_jk for unmapped request

High 7.5

In plain English

A high-severity security flaw in Apache Tomcat Connectors from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 76% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)1.6%top 24.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Important: Authentication Bypass CVE-2023-41081 The mod_jk component of Apache Tomcat Connectors in some circumstances, such as when a configuration included "JkOptions +ForwardDirectories" but the configuration did not provide explicit mounts for all possible proxied requests, mod_jk would use an implicit mapping and map the request to the first defined worker. Such an implicit mapping could result in the unintended exposure of the status worker and/or bypass security constraints configured in httpd. As of JK 1.2.49, the implicit mapping functionality has been removed and all mappings must now be via explicit configuration. Only mod_jk is affected by this issue. The ISAPI redirector is not affected. This issue affects Apache Tomcat Connectors (mod_jk only): from 1.2.0 through 1.2.48. Users are recommended to upgrade to version 1.2.49, which fixes the issue. History 2023-09-13 Original advisory 2023-09-28 Updated summary

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:9mod_jk1.2.49-1.el9_4ALSA-2024:2387
AlmaLinux:9mod_proxy_cluster1.3.20-1.el9_4ALSA-2024:2387
Debian:12libapache-mod-jk1:1.2.48-2+deb12u1DEBIAN-CVE-2023-41081
Debian:13libapache-mod-jk1:1.2.49-1DEBIAN-CVE-2023-41081
Debian:14libapache-mod-jk1:1.2.49-1DEBIAN-CVE-2023-41081
Ubuntu:22.04:LTSlibapache-mod-jk1:1.2.48-1ubuntu0.1USN-6826-1
Ubuntu:22.04:LTSlibapache-mod-jk1:1.2.48-1ubuntu0.1UBUNTU-CVE-2023-41081

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat Connectors 1.2.0 – through 1.2.48

References