Vulnerability · Published Sep 25, 2023 · Assigned by GitHub_M

CVE-2023-40581yt-dlp command injection when using `%q` in `--exec` on Windows

High 8.4

In plain English

A high-severity OS command injection in yt-dlp from yt-dlp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 71% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.4High
Exploit odds (30 days)1.3%top 28.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

yt-dlp is a youtube-dl fork with additional features and fixes. yt-dlp allows the user to provide shell command lines to be executed at various stages in its download steps through the `--exec` flag. This flag allows output template expansion in its argument, so that metadata values may be used in the shell commands. The metadata fields can be combined with the `%q` conversion, which is intended to quote/escape these values so they can be safely passed to the shell. However, the escaping used for `cmd` (the shell used by Python's `subprocess` on Windows) does not properly escape special characters, which can allow for remote code execution if `--exec` is used directly with maliciously crafted remote data. This vulnerability only impacts `yt-dlp` on Windows, and the vulnerability is present regardless of whether `yt-dlp` is run from `cmd` or from `PowerShell`. Support for output template expansion in `--exec`, along with this vulnerable behavior, was added to `yt-dlp` in version 2021.04.11. yt-dlp version 2023.09.24 fixes this issue by properly escaping each special character. `\n` will be replaced by `\r` as no way of escaping it has been found. It is recommended to upgrade yt-dlp to version 2023.09.24 as soon as possible. Also, always be careful when using --exec, because while this specific vulnerability has been patched, using unvalidated input in shell commands is inherently dangerous. For Windows users who are not able to upgrade: 1. Avoid using any output template expansion in --exec other than {} (filepath). 2. If expansion in --exec is needed, verify the fields you are using do not contain ", | or &. 3. Instead of using --exec, write the info json and load the fields from it instead.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20yt-dlp0-r0ALPINE-CVE-2023-40581
Alpine:v3.21yt-dlp0-r0ALPINE-CVE-2023-40581
Alpine:v3.22yt-dlp0-r0ALPINE-CVE-2023-40581
Alpine:v3.23yt-dlp0-r0ALPINE-CVE-2023-40581
Alpine:v3.24yt-dlp0-r0ALPINE-CVE-2023-40581
PyPIyt-dlp2023.09.24GHSA-42h4-v29r-42qg
PyPIyt-dlp2023.09.24PYSEC-2026-2064

Affected products (as reported)

VendorProductVersions
yt-dlp yt-dlp >= 2021.04.11, < 2023.09.24< nightly 2023.09.24.003044

Weakness: CWE-78 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H

References