Vulnerability · Published Aug 25, 2023 · Assigned by GitHub_M
CVE-2023-40579OpenFGA Authorization Bypass
Medium 6.5
In plain English
A medium-severity improper access control in openfga from openfga. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
OpenFGA is an authorization/permission engine built for developers and inspired by Google Zanzibar. Some end users of OpenFGA v1.3.0 or earlier are vulnerable to authorization bypass when calling the ListObjects API. The vulnerability affects customers using `ListObjects` with specific models. The affected models contain expressions of type `rel1 from type1`. This issue has been patched in version 1.3.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/openfga/openfga | 1.3.1 | GHSA-jcf2-mxr2-gmqp |
| Go | github.com/openfga/openfga | 1.3.1 | GO-2023-2028 |
Affected products (as reported)
Weakness: CWE-284 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
References
- https://github.com/openfga/openfga/security/advisories/GHSA-jcf2-mxr2-gmqp x_refsource_CONFIRM
- https://github.com/openfga/openfga/releases/tag/v1.3.1 x_refsource_MISC