Vulnerability · Published Aug 25, 2023 · Assigned by GitHub_M
CVE-2023-40577Alertmanager UI is vulnerable to stored XSS via the /api/v1/alerts endpoint
High 7.5
In plain English
A high-severity cross-site scripting in alertmanager from prometheus. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Alertmanager handles alerts sent by client applications such as the Prometheus server. An attacker with the permission to perform POST requests on the /api/v1/alerts endpoint could be able to execute arbitrary JavaScript code on the users of Prometheus Alertmanager. This issue has been fixed in Alertmanager version 0.2.51.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.20 | alertmanager | 0.26.0-r0 | ALPINE-CVE-2023-40577 |
| Alpine:v3.21 | alertmanager | 0.26.0-r0 | ALPINE-CVE-2023-40577 |
| Alpine:v3.22 | alertmanager | 0.26.0-r0 | ALPINE-CVE-2023-40577 |
| Alpine:v3.23 | alertmanager | 0.26.0-r0 | ALPINE-CVE-2023-40577 |
| Alpine:v3.24 | alertmanager | 0.26.0-r0 | ALPINE-CVE-2023-40577 |
| Debian:12 | prometheus-alertmanager | no fix listed | DEBIAN-CVE-2023-40577 |
| Debian:13 | prometheus-alertmanager | 0.26.0+ds-1 | DEBIAN-CVE-2023-40577 |
| Debian:14 | prometheus-alertmanager | 0.26.0+ds-1 | DEBIAN-CVE-2023-40577 |
| Go | github.com/prometheus/alertmanager | 0.25.1 | GO-2023-2020 |
| Go | github.com/prometheus/alertmanager | 0.25.1 | GHSA-v86x-5fm3-5p7j |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| prometheus | alertmanager | <= 0.25.0 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N