Vulnerability · Published Aug 17, 2023 · Assigned by OpenNMS
CVE-2023-40313Disable BeanShell Interpreter Remote Server Mode
High 7.1
In plain English
A high-severity code injection in Horizon from The OpenNMS Group. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
A BeanShell interpreter in remote server mode runs in OpenMNS Horizon versions earlier than 32.0.2 and in related Meridian versions which could allow arbitrary remote Java code execution. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.opennms:opennms-base-assembly | 32.0.2 | GHSA-5m5f-qg8r-p9qf |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| The OpenNMS Group | Horizon | 29.0.4 – before 32.0.2 |
| The OpenNMS Group | Meridian | 2020.0.0 – through 2020.1.372021.0.0 – through 2021.1.292022.0.0 – through 2022.1.182023.0.0 – through 2023.1.5 |
Weakness: CWE-94 · Vector: CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L