Vulnerability · Published Aug 14, 2023 · Assigned by OpenNMS
CVE-2023-40311Stored XSS in multiple JSP files in opennms/opennms
Medium 6.7
In plain English
A medium-severity cross-site scripting in Horizon from The OpenNMS Group. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Multiple stored XSS were found on different JSP files with unsanitized parameters in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms that allow an attacker to store on database and then load on JSPs or Angular templates. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Jordi Miralles Comins for reporting this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.opennms:opennms-webapp | 32.0.2 | GHSA-qfw7-pfxx-h9q2 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| The OpenNMS Group | Horizon | 31.0.8 – before 32.0.2 |
| The OpenNMS Group | Meridian | 2020.0.0 – through 2020.1.372021.0.0 – through 2021.1.292022.0.0 – through 2022.1.182023.0.0 – through 2023.1.5 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N