Vulnerability · Published Aug 23, 2023 · Assigned by GitHub_M

CVE-2023-40178@node-saml/node-saml's validatePostRequestAsync does not include checkTimestampsValidityError

Medium 5.3

In plain English

A medium-severity security flaw in node-saml from node-saml. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.5%top 57.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Node-SAML is a SAML library not dependent on any frameworks that runs in Node. The lack of checking of current timestamp allows a LogoutRequest XML to be reused multiple times even when the current time is past the NotOnOrAfter. This could impact the user where they would be logged out from an expired LogoutRequest. In bigger contexts, if LogoutRequests are sent out in mass to different SPs, this could impact many users on a large scale. This issue was patched in version 4.0.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@node-saml/node-saml4.0.5GHSA-vx8m-6fhw-pccw

Affected products (as reported)

VendorProductVersions
node-saml node-saml < 4.0.5

Weakness: CWE-347 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

References