Vulnerability · Published Aug 9, 2023 · Assigned by GitHub_M
CVE-2023-39531Sentry vulnerable to incorrect credential validation on OAuth token requests
Medium 6.5
In plain English
A medium-severity improper authentication in sentry from getsentry. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Sentry is an error tracking and performance monitoring platform. Starting in version 10.0.0 and prior to version 23.7.2, an attacker with sufficient client-side exploits could retrieve a valid access token for another user during the OAuth token exchange due to incorrect credential validation. The client ID must be known and the API application must have already been authorized on the targeted user account. Sentry SaaS customers do not need to take any action. Self-hosted installations should upgrade to version 23.7.2 or higher. There are no direct workarounds, but users should review applications authorized on their account and remove any that are no longer needed.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | sentry | 23.7.2 | GHSA-hgj4-h2x3-rfx4 |
| PyPI | sentry | 23.7.2 | PYSEC-2026-1915 |
Affected products (as reported)
Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:L/A:N
References
- https://github.com/getsentry/sentry/security/advisories/GHSA-hgj4-h2x3-rfx4 x_refsource_CONFIRM