Vulnerability · Published Sep 29, 2023 · Assigned by apache
CVE-2023-39410Apache Avro Java SDK: Memory when deserializing untrusted data in Avro Java SDK
High 7.5
In plain English
A high-severity unsafe deserialization in Apache Avro Java SDK from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.2% (higher than 83% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
When deserializing untrusted or corrupted data, it is possible for a reader to consume memory beyond the allowed constraints and thus lead to out of memory on the system. This issue affects Java applications using Apache Avro Java SDK up to and including 1.11.2. Users should update to apache-avro version 1.11.3 which addresses this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.avro:avro | 1.11.3 | GHSA-rhrv-645h-fjfh |
| PyPI | avro | 1.11.3 | PYSEC-2023-188 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Avro Java SDK | 0 – before 1.11.3 |
Weakness: CWE-502