Vulnerability · Published Jul 27, 2023 · Assigned by GitHub_M
CVE-2023-38510Tolgee Lacks Permission Check for API Key for some endpoints
High 8.1
In plain English
A high-severity missing authorization in tolgee-platform from tolgee. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities).
Official description
Tolgee is an open-source localization platform. Starting in version 3.14.0 and prior to version 3.23.1, when a request is made using an API key, the backend fails to verify the permission scopes associated with the key, effectively bypassing permission checks entirely for some endpoints. It's important to note that this vulnerability only affects projects that have inadvertently exposed their API keys on the internet. Projects that have kept their API keys secure are not impacted. This issue is fixed in version 3.23.1.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| tolgee | tolgee-platform | >= 3.14.0, < 3.23.1 |
Weakness: CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
References
- https://github.com/tolgee/tolgee-platform/security/advisories/GHSA-4f9j-4vh4-p85v x_refsource_CONFIRM
- https://github.com/tolgee/tolgee-platform/pull/1818 x_refsource_MISC
- https://github.com/tolgee/tolgee-platform/commit/4776cba67e7bb8c1b0259376e3e5fa3bb46e45c7 x_refsource_MISC
- https://github.com/tolgee/tolgee-platform/releases/tag/v3.23.1 x_refsource_MISC