Vulnerability · Published Jul 27, 2023 · Assigned by GitHub_M
CVE-2023-38504Sails DoS vulnerability for apps with sockets enabled
High 7.5
In plain English
A high-severity security flaw in sails from balderdashy. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 61% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.9%top 39.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Sails is a realtime MVC Framework for Node.js. In Sails apps prior to version 1.5.7,, an attacker can send a virtual request that will cause the node process to crash. This behavior was fixed in Sails v1.5.7. As a workaround, disable the sockets hook and remove the `sails.io.js` client.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | sails | 1.5.7 | GHSA-gpw9-fwm8-7rx7 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| balderdashy | sails | < 1.5.7 |
Weakness: CWE-248 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/balderdashy/sails/security/advisories/GHSA-gpw9-fwm8-7rx7 x_refsource_CONFIRM
- https://github.com/balderdashy/sails/pull/7287 x_refsource_MISC
- https://github.com/balderdashy/sails/commit/4a023dc5095a4b30fdc8535f705ed34cd22d2f7d x_refsource_MISC
- https://github.com/balderdashy/sails/releases/tag/v1.5.7 x_refsource_MISC