Vulnerability · Published Jul 27, 2023 · Assigned by GitHub_M
CVE-2023-38495Crossplane vulnerable to possible image tampering from missing image validation for Packages
High 8.4
In plain English
A high-severity improper input validation in crossplane from crossplane. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 58% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Crossplane is a framework for building cloud native control planes without needing to write code. In versions prior to 1.11.5, 1.12.3, and 1.13.0, Crossplane's image backend does not validate the byte contents of Crossplane packages. As such, Crossplane does not detect if an attacker has tampered with a Package. The problem has been fixed in 1.11.5, 1.12.3 and 1.13.0. As a workaround, only use images from trusted sources and keep Package editing/creating privileges to administrators only.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/crossplane/crossplane | 1.11.5 | GHSA-pj4x-2xr5-w87m |
| Go | github.com/crossplane/crossplane | 1.12.3 | GHSA-pj4x-2xr5-w87m |
| Go | github.com/crossplane/crossplane | 1.11.5, 1.12.3 | GO-2023-1980 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| crossplane | crossplane | < 1.11.5>= 1.12.0, < 1.12.3 |
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H