Vulnerability · Published Jul 27, 2023 · Assigned by GitHub_M

CVE-2023-38492Kirby vulnerable to denial of service from unlimited password lengths

Medium 5.3

In plain English

A medium-severity resource allocation without limits in kirby from getkirby. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)1.2%top 32.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Kirby is a content management system. A vulnerability in versions prior to 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6 affects all Kirby sites with user accounts (unless Kirby's API and Panel are disabled in the config). The real-world impact of this vulnerability is limited, however we still recommend to update to one of the patch releases because they also fix more severe vulnerabilities. Kirby's authentication endpoint did not limit the password length. This allowed attackers to provide a password with a length up to the server's maximum request body length. Validating that password against the user's actual password requires hashing the provided password, which requires more CPU and memory resources (and therefore processing time) the longer the provided password gets. This could be abused by an attacker to cause the website to become unresponsive or unavailable. Because Kirby comes with a built-in brute force protection, the impact of this vulnerability is limited to 10 failed logins from each IP address and 10 failed logins for each existing user per hour. The problem has been patched in Kirby 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6. In all of the mentioned releases, the maintainers have added password length limits in the affected code so that passwords longer than 1000 bytes are immediately blocked, both when setting a password and when logging in.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistgetkirby/cms3.5.8.3GHSA-3v6j-v3qc-cxff
Packagistgetkirby/cms3.6.6.3GHSA-3v6j-v3qc-cxff
Packagistgetkirby/cms3.7.5.2GHSA-3v6j-v3qc-cxff
Packagistgetkirby/cms3.8.4.1GHSA-3v6j-v3qc-cxff
Packagistgetkirby/cms3.9.6GHSA-3v6j-v3qc-cxff

Affected products (as reported)

VendorProductVersions
getkirby kirby < 3.5.8.3>= 3.6.0, < 3.6.6.3>= 3.7.0, < 3.7.5.2>= 3.8.0, < 3.8.41>= 3.9.0, < 3.9.6

Weakness: CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

References