Vulnerability · Published Nov 17, 2023 · Assigned by mitre
CVE-2023-38316
Critical 9.8
In plain English
A critical-severity security flaw in the opennds package (Debian). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
An issue was discovered in OpenNDS Captive Portal before version 10.1.2. When the custom unescape callback is enabled, attackers can execute arbitrary OS commands by inserting them into the URL portion of HTTP GET requests. Affected OpenNDS Captive Portal before version 10.1.2 fixed in OpenWrt master, OpenWrt 23.05 and OpenWrt 22.03 on 28. August 2023 by updating OpenNDS to version 10.1.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | opennds | no fix listed | DEBIAN-CVE-2023-38316 |
| Debian:13 | opennds | 10.2.0+dfsg-1 | DEBIAN-CVE-2023-38316 |