Vulnerability · Published Nov 17, 2023 · Assigned by mitre

CVE-2023-38314

Medium 6.5

In plain English

A medium-severity security flaw in the opennds package (Debian). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 61% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)6.5Medium
Exploit odds (30 days)0.9%top 39.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

An issue was discovered in OpenNDS Captive Portal before version 10.1.2. It has a NULL pointer dereference in preauthenticated() that can be triggered with a crafted GET HTTP request with a missing redirect query string parameter. Triggering this issue results in crashing OpenNDS (a Denial-of-Service condition). Affected OpenNDS Captive Portal before version 10.1.2 fixed infixed in OpenWrt master, OpenWrt 23.05 and OpenWrt 22.03 on28. August 2023 by updating OpenNDS to version 10.1.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12openndsno fix listedDEBIAN-CVE-2023-38314
Debian:13opennds10.2.0+dfsg-1DEBIAN-CVE-2023-38314

Affected products (as reported)

VendorProductVersions
n/a n/a n/a

References