Vulnerability · Published Nov 22, 2023 · Assigned by apache

CVE-2023-37924Apache Submarine: SQL injection from unauthorized login

Critical 9.8

In plain English

A critical-severity SQL injection in Apache Submarine from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 7.2% (higher than 94% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)9.8Critical
Exploit odds (30 days)7.2%top 5.7% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Apache Software Foundation Apache Submarine has an SQL injection vulnerability when a user logs in. This issue can result in unauthorized login. Now we have fixed this issue and now user must have the correct login to access workbench. This issue affects Apache Submarine: from 0.7.0 before 0.8.0. We recommend that all submarine users with 0.7.0 upgrade to 0.8.0, which not only fixes the issue, supports the oidc authentication mode, but also removes the case of unauthenticated logins. If using the version lower than 0.8.0 and not want to upgrade, you can try cherry-pick PR https://github.com/apache/submarine/pull/1037 https://github.com/apache/submarine/pull/1054 and rebuild the submarine-server image to fix this.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIapache-submarine0.8.0GHSA-v5gj-fx3g-hcpw
PyPIapache-submarine0.8.0PYSEC-2023-244

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Submarine 0.7.0 – before 0.8.0

Weakness: CWE-89

References