Vulnerability · Published Jul 25, 2023 · Assigned by GitHub_M
CVE-2023-37257The DataEase panel and dataset have a stored XSS vulnerability
Medium 5.4
In plain English
A medium-severity cross-site scripting in dataease from dataease. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities).
Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)0.4%top 62.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known
Official description
DataEase is an open source data visualization analysis tool. Prior to version 1.18.9, the DataEase panel and dataset have a stored cross-site scripting vulnerability. The vulnerability has been fixed in v1.18.9. There are no known workarounds.
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
References
- https://github.com/dataease/dataease/security/advisories/GHSA-7cm3-9pp6-q2fq x_refsource_CONFIRM
- https://github.com/dataease/dataease/releases/tag/v1.18.9 x_refsource_MISC