Vulnerability · Published Jul 5, 2023 · Assigned by GitHub_M
CVE-2023-36827Fides vulnerable to Path Traversal in Webserver API
High 7.5
In plain English
A high-severity path traversal in fides from ethyca. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.5% (higher than 74% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Fides is an open-source privacy engineering platform for managing the fulfillment of data privacy requests in a runtime environment, and the enforcement of privacy regulations in code. A path traversal (directory traversal) vulnerability affects fides versions lower than version `2.15.1`, allowing remote attackers to access arbitrary files on the fides webserver container's filesystem. The vulnerability is patched in fides `2.15.1`. If the Fides webserver API is not directly accessible to attackers and is instead deployed behind a reverse proxy as recommended in Ethyca's security best practice documentation, and the reverse proxy is an AWS application load balancer, the vulnerability can't be exploited by these attackers. An AWS application load balancer will reject this attack with a 400 error. Additionally, any secrets supplied to the container using environment variables rather than a `fides.toml` configuration file are not affected by this vulnerability.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | ethyca-fides | 2.15.1 | GHSA-r25m-cr6v-p9hq |
| PyPI | ethyca-fides | 2.15.1 | PYSEC-2023-107 |
Affected products (as reported)
Weakness: CWE-22 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
References
- https://github.com/ethyca/fides/security/advisories/GHSA-r25m-cr6v-p9hq x_refsource_CONFIRM
- https://github.com/ethyca/fides/commit/f526d9ffb176006d701493c9d0eff6b4884e811f x_refsource_MISC
- https://github.com/ethyca/fides/releases/tag/2.15.1 x_refsource_MISC