Vulnerability · Published Jul 25, 2023 · Assigned by GitHub_M

CVE-2023-36826Sentry vulnerable to improper authorization on debug and artifact file downloads

High 7.7

In plain English

A high-severity incorrect authorization in sentry from getsentry. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.7High
Exploit odds (30 days)0.6%top 49.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Sentry is an error tracking and performance monitoring platform. Starting in version 8.21.0 and prior to version 23.5.2, an authenticated user can download a debug or artifact bundle from arbitrary organizations and projects with a known bundle ID. The user does not need to be a member of the organization or have permissions on the project. A patch was issued in version 23.5.2 to ensure authorization checks are properly scoped on requests to retrieve debug or artifact bundles. Authenticated users who do not have the necessary permissions on the particular project are no longer able to download them. Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version 23.5.2 or higher.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIsentry23.5.2GHSA-m4hc-m2v6-hfw8
PyPIsentry23.5.2PYSEC-2023-130

Affected products (as reported)

VendorProductVersions
getsentry sentry >= 8.21.0, < 23.5.2

Weakness: CWE-285, CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N

References