Vulnerability · Published Oct 6, 2023 · Assigned by GitHub_M

CVE-2023-36465Decidim has broken access control in templates

Critical 9.1

In plain English

A critical-severity improper access control in decidim from decidim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)0.7%top 47.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. The `templates` module doesn't enforce the correct permissions, allowing any logged-in user to access to this functionality in the administration panel. An attacker could use this vulnerability to change, create or delete templates of surveys. This issue has been patched in version 0.26.8 and 0.27.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsdecidim0.26.8GHSA-639h-86hw-qcjq
RubyGemsdecidim0.27.4GHSA-639h-86hw-qcjq
RubyGemsdecidim-templates0.26.8GHSA-639h-86hw-qcjq
RubyGemsdecidim-templates0.27.4GHSA-639h-86hw-qcjq

Affected products (as reported)

VendorProductVersions
decidim decidim >= 0.23.2, < 0.26.8>= 0.27.0, < 0.27.4

Weakness: CWE-284 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:L

References