Vulnerability · Published Jun 30, 2023 · Assigned by GitHub_M

CVE-2023-35946Dependency cache path traversal in Gradle

Medium 6.9

In plain English

A medium-severity path traversal in gradle from gradle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 21% of all known vulnerabilities).

Severity (CVSS 3.1)6.9Medium
Exploit odds (30 days)0.3%top 79.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Gradle is a build tool with a focus on build automation and support for multi-language development. When Gradle writes a dependency into its dependency cache, it uses the dependency's coordinates to compute a file location. With specially crafted dependency coordinates, Gradle can be made to write files into an unintended location. The file may be written outside the dependency cache or over another file in the dependency cache. This vulnerability could be used to poison the dependency cache or overwrite important files elsewhere on the filesystem where the Gradle process has write permissions. Exploiting this vulnerability requires an attacker to have control over a dependency repository used by the Gradle build or have the ability to modify the build's configuration. It is unlikely that this would go unnoticed. A fix has been released in Gradle 7.6.2 and 8.2 to protect against this vulnerability. Gradle will refuse to cache dependencies that have path traversal elements in their dependency coordinates. It is recommended that users upgrade to a patched version. If you are unable to upgrade to Gradle 7.6.2 or 8.2, `dependency verification` will make this vulnerability more difficult to exploit.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12gradleno fix listedDEBIAN-CVE-2023-35946
Debian:13gradleno fix listedDEBIAN-CVE-2023-35946
Debian:14gradleno fix listedDEBIAN-CVE-2023-35946
Ubuntu:22.04:LTSgradleno fix listedUBUNTU-CVE-2023-35946
Ubuntu:24.04:LTSgradleno fix listedUBUNTU-CVE-2023-35946
Ubuntu:25.10gradleno fix listedUBUNTU-CVE-2023-35946
Ubuntu:26.04:LTSgradleno fix listedUBUNTU-CVE-2023-35946
Ubuntu:26.10gradleno fix listedUBUNTU-CVE-2023-35946

Affected products (as reported)

VendorProductVersions
gradle gradle < 7.6.2>= 8.0, < 8.2

Weakness: CWE-22 · Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:L/I:H/A:L

References