Vulnerability · Published Jun 19, 2023 · Assigned by apache

CVE-2023-35005Apache Airflow: Information disclosure on configuration view

Medium 6.5

In plain English

A medium-severity information exposure in Apache Airflow from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.5% (higher than 75% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)6.5Medium
Exploit odds (30 days)1.5%top 25.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

In Apache Airflow, some potentially sensitive values were being shown to the user in certain situations. This vulnerability is mitigated by the fact configuration is not shown in the UI by default (only if `[webserver] expose_config` is set to `non-sensitive-only`), and not all uncensored values are actually sentitive. This issue affects Apache Airflow: from 2.5.0 before 2.6.2. Users are recommended to update to version 2.6.2 or later.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIapache-airflow2.6.2rc1GHSA-mjff-wv85-hmcj
PyPIapache-airflow2.6.2PYSEC-2023-89

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Airflow 2.5.0 – before 2.6.2

Weakness: CWE-200

References