Vulnerability · Published Jun 22, 2023 · Assigned by GitHub_M

CVE-2023-34462netty-handler SniHandler 16MB allocation

Medium 6.5

In plain English

A medium-severity uncontrolled resource consumption in netty from netty. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.5% (higher than 85% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)2.5%top 15.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. The `SniHandler` can allocate up to 16MB of heap for each channel during the TLS handshake. When the handler or the channel does not have an idle timeout, it can be used to make a TCP server using the `SniHandler` to allocate 16MB of heap. The `SniHandler` class is a handler that waits for the TLS handshake to configure a `SslHandler` according to the indicated server name by the `ClientHello` record. For this matter it allocates a `ByteBuf` using the value defined in the `ClientHello` record. Normally the value of the packet should be smaller than the handshake packet but there are not checks done here and the way the code is written, it is possible to craft a packet that makes the `SslClientHelloHandler`. This vulnerability has been fixed in version 4.1.94.Final.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12netty1:4.1.48-7+deb12u1DSA-5558-1
Debian:12netty1:4.1.48-7+deb12u1DEBIAN-CVE-2023-34462
Debian:13netty1:4.1.48-8DEBIAN-CVE-2023-34462
Debian:14netty1:4.1.48-8DEBIAN-CVE-2023-34462
Mavenio.netty:netty-handler4.1.94.FinalGHSA-6mjq-h674-j845
Ubuntu:22.04:LTSnetty1:4.1.48-4+deb11u2build0.22.04.1USN-6994-1
Ubuntu:22.04:LTSnetty1:4.1.48-4+deb11u2build0.22.04.1UBUNTU-CVE-2023-34462
Ubuntu:24.04:LTSnetty1:4.1.48-9UBUNTU-CVE-2023-34462
Ubuntu:25.10nettyno fix listedUBUNTU-CVE-2023-34462
Ubuntu:26.10nettyno fix listedUBUNTU-CVE-2023-34462

Affected products (as reported)

VendorProductVersions
netty netty < 4.1.94.Final

Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

References