Vulnerability · Published Jun 21, 2023 · Assigned by apache
CVE-2023-34340Apache Accumulo: Accumulo 2.1.0 may incorrectly validate cached credentials
Critical 9.8
In plain English
A critical-severity improper authentication in Apache Accumulo from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 73% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Improper Authentication vulnerability in Apache Software Foundation Apache Accumulo. This issue affects Apache Accumulo: 2.1.0. Accumulo 2.1.0 contains a defect in the user authentication process that may succeed when invalid credentials are provided. Users are advised to upgrade to 2.1.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.accumulo:accumulo-shell | 2.1.1 | GHSA-hp5w-w29m-vg63 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Accumulo | 2.1.0 – before 2.1.1 |
Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
References
- https://lists.apache.org/thread/syy6jftvy9l6tlhn33o0rzwhh4rd0z4t vendor-advisory, mailing-list
- https://accumulo.apache.org/release/accumulo-2.1.1/ release-notes