Vulnerability · Published Jun 12, 2023 · Assigned by GitHub_M

CVE-2023-34246Doorkeeper Improper Authentication vulnerability

Medium 4.2

In plain English

A medium-severity improper authentication in doorkeeper from doorkeeper-gem. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.2Medium
Exploit odds (30 days)0.7%top 46.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Doorkeeper is an OAuth 2 provider for Ruby on Rails / Grape. Prior to version 5.6.6, Doorkeeper automatically processes authorization requests without user consent for public clients that have been previous approved. Public clients are inherently vulnerable to impersonation, their identity cannot be assured. This issue is fixed in version 5.6.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ruby-doorkeeper5.5.0-2+deb12u1DEBIAN-CVE-2023-34246
Debian:13ruby-doorkeeper5.6.6-2DEBIAN-CVE-2023-34246
Debian:14ruby-doorkeeper5.6.6-2DEBIAN-CVE-2023-34246
RubyGemsdoorkeeper5.6.6GHSA-7w2c-w47h-789w
Ubuntu:22.04:LTSruby-doorkeeper5.5.0-2ubuntu0.22.04.1USN-6210-1
Ubuntu:22.04:LTSruby-doorkeeper5.5.0-2ubuntu0.22.04.1UBUNTU-CVE-2023-34246

Affected products (as reported)

VendorProductVersions
doorkeeper-gem doorkeeper < 5.6.6

Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N

References