Vulnerability · Published Jun 22, 2023 · Assigned by GitHub_M

CVE-2023-34110Flask-AppBuilder vulnerable to possible disclosure of sensitive information on user error

Low 2.7

In plain English

A low-severity security flaw in Flask-AppBuilder from dpgaspar. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)2.7Low
Exploit odds (30 days)0.7%top 47.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Flask-AppBuilder is an application development framework, built on top of Flask. Prior to version 4.3.2, an authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password. This vulnerability has been fixed in version 4.3.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIflask-appbuilder4.3.2GHSA-jhpr-j7cq-3jp3
PyPIflask-appbuilder4.3.2PYSEC-2023-94

Affected products (as reported)

VendorProductVersions
dpgaspar Flask-AppBuilder < 4.3.2

Weakness: CWE-209 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N

References