Vulnerability · Published Jun 1, 2023 · Assigned by GitHub_M
CVE-2023-34092Vite Server Options (server.fs.deny) can be bypassed using double forward-slash (//)
High 7.5
In plain English
A high-severity information exposure in vite from vitejs. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 3.2% (higher than 88% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei. Fixed versions are available - upgrade the affected package.
Official description
Vite provides frontend tooling. Prior to versions 2.9.16, 3.2.7, 4.0.5, 4.1.5, 4.2.3, and 4.3.9, Vite Server Options (`server.fs.deny`) can be bypassed using double forward-slash (//) allows any unauthenticated user to read file from the Vite root-path of the application including the default `fs.deny` settings (`['.env', '.env.*', '*.{crt,pem}']`). Only users explicitly exposing the Vite dev server to the network (using `--host` or `server.host` config option) are affected, and only files in the immediate Vite project root folder could be exposed. This issue is fixed in vite@4.3.9, vite@4.2.3, vite@4.1.5, vite@4.0.5, vite@3.2.7, and vite@2.9.16.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | vite | 2.9.16 | GHSA-353f-5xf4-qw67 |
| npm | vite | 3.2.7 | GHSA-353f-5xf4-qw67 |
| npm | vite | 4.0.5 | GHSA-353f-5xf4-qw67 |
| npm | vite | 4.1.5 | GHSA-353f-5xf4-qw67 |
| npm | vite | 4.2.3 | GHSA-353f-5xf4-qw67 |
| npm | vite | 4.3.9 | GHSA-353f-5xf4-qw67 |
Affected products (as reported)
Weakness: CWE-50, CWE-200 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
References
- https://github.com/vitejs/vite/security/advisories/GHSA-353f-5xf4-qw67 x_refsource_CONFIRM
- https://github.com/vitejs/vite/pull/13348 x_refsource_MISC
- https://github.com/vitejs/vite/commit/813ddd6155c3d54801e264ba832d8347f6f66b32 x_refsource_MISC