Vulnerability · Published Jul 11, 2023 · Assigned by GitHub_M

CVE-2023-34089Decidim Cross-site Scripting vulnerability in the processes filter

High 8.1

In plain English

A high-severity cross-site scripting in decidim from decidim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.7%top 45.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. The processes filter feature is susceptible to Cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing. The problem was patched in version 0.27.3 and 0.26.7.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsdecidim0.26.7GHSA-5652-92r9-3fx9
RubyGemsdecidim0.27.3GHSA-5652-92r9-3fx9
RubyGemsdecidim-core0.26.7GHSA-5652-92r9-3fx9
RubyGemsdecidim-core0.27.3GHSA-5652-92r9-3fx9

Affected products (as reported)

VendorProductVersions
decidim decidim >= 0.14.0, < 0.26.7>= 0.27.0, < 0.27.3

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

References