Vulnerability · Published May 31, 2023 · Assigned by GitHub_M
CVE-2023-34088Collabora Online has Stored Cross-Site-Scripting vulnerability in admin interface
High 8.7
In plain English
A high-severity cross-site scripting in online from CollaboraOnline. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities).
Official description
Collabora Online is a collaborative online office suite. A stored cross-site scripting (XSS) vulnerability was found in Collabora Online prior to versions 22.05.13, 21.11.9.1, and 6.4.27. An attacker could create a document with an XSS payload as a document name. Later, if an administrator opened the admin console and navigated to the history page, the document name was injected as unescaped HTML and executed as a script inside the context of the admin console. The administrator JSON web token (JWT) used for the websocket connection could be leaked through this flaw. Users should upgrade to Collabora Online 22.05.13 or higher; Collabora Online 21.11.9.1 or higher; Collabora Online 6.4.27 or higher to receive a patch.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| CollaboraOnline | online | coolwsd < 22.05.13coolwsd < 21.11.9.1loolwsd < 6.4.27 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N